XXIKU - FREE.XXIKU.COM is down – Incident details
Email
Telegram
Get updates
Email
SMS
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Email
Telegram
Get updates
All systems operational
FREE.XXIKU.COM is down
Resolved
Major outage
Started about 19 hours ago
Lasted about 7 hours
Affected
FREE.XXIKU.COM
Operational from 2:46 AM to 2:46 AM, Major outage from 2:46 AM to 9:31 AM
Updates
Resolved
September 03, 2025 at 9:31 AM
Resolved
September 03, 2025 at 9:31 AM
FREE.XXIKU.COM is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
September 03, 2025 at 2:46 AM
Investigating
September 03, 2025 at 2:46 AM
FREE.XXIKU.COM is down at the moment. This incident was automatically created by Instatus monitoring.